Questions and Answers

Dear developers!

You canfindanswers to your questions on the forum pages and add a new topic to discuss the problem with our engineers.

We suggest you to readWiKi, where you can find the full description of the functionality of our products.Pleaseregisterand ask your question.

Please, don't forget to subscribe to new topics to keep track of the status of your question.
You will be informed by e-mail when our engineer respond to the message

Search  Users  Rules 
Forgot your password?
Pages: Prev. 1 2 3
Questions and Answers, SAU510, SAU100, emulators, FAQ
This error isn't related to version of windows or drivers. This error may be caused by poor TCK signal, by very high frequency of TCK, by glitches on the power or reset signals of target processor. Check that grounds of target PCB and PC are strong coupled. Attempt to change (lower) TCK frequency and/or TCK termination (by editing ccbrd0.dat - it is generated by CCS Setup, and then used by CCS to configure emulator).

Also, we didn't test emulator drivers under VmWare, and don't guarantee work and/or performance of emulation. We support only native Windows or Linux installations.
Further to my efforts to get an old sm510usb running with CCS 2.21 on Win7 32bit, we now have the first of our new sau510usb-iso plus v2 pods and are again having difficulties with ccs 2.21:

We installed the driver from the supplied CD (the readme file says version 1.01.0003.1). This failed to pick up the pod first time but eventually recognised it in device manager.

We configured CCS to use the supplied brddat file sm510usb-iso.cfg. CCS fails to launch with a -247 error. We then ran the following diagnostic:
xdsprobe.exe -p 0x240 -f c:\ti\cc\bin\Brddat\sm510usb-iso.cfg

This utility has `-h' and `-vh' options
that provide brief help and a full manual.

This utility will load the emulator adapter `sm510usb.dll'.
This utility has selected a XDS510 class product.
This utility will operate on port address `0x0240'.

---[An error has occurred and this utility has aborted]---------

This error is generated by TI's USCIF driver.

The error's value is: `-247'.
The error's title is: `SC_ERR_BRD_VAR_VALUE'.

The error's explanation is:
Failed to find the specified variable value in the board data.

Is there an issue with the sm510usb-iso.cfg file?? I tried putting single quotes around some of the numeric values as you recommended before but nothing worked.

I then plugged the old sm510usb pod in and the (new) driver recognised it. I then re-configured CCS with the supplied sm510usb.cfg file and it worked ok.

Any ideas how to get the new iso pod to work?
Many thanks
After updating of "sm510usb*.cfg" file you MUST reconfigure CCS to apply changes. Or you can modify directly "brddat/ccbrd0.dat" file, generated by CCS Setup.
Hi Sergey and thanks for the reply.

I am sorry but I dont understand what it is I need to do. We have re-run Setup CCS 2 and selected 'auto generate board data file with extra configuration file' + sm510 cfg file but we still get the CCS 2 error. Please can you tell me if I need to modify the sm510usb-iso.cfg file in any way to run with CCS 2.21?

Here is three ways:

1) Use original .cfg file, then run setup CCStudio, exit with saving but without starting CCS, then edit "CCBrd0.dat" directly.

2) Edit configuration file that you want use as additional configuration file (as needed for emulator that you want use). Then run "Setup CCStudio", then regenerate configuration, save and run CCS.

3) Install latest driver from our site. It contains patched .cfg files. Then regenerate CCS configuration.
Yes I kind of gathered that after I had replied to you! We now have the new pod working thanks.

We edited ccBrd0.dat so that
We also had to set [POD_SLOWCLK] YES, but this is probably an issue with our old target hardware.

Many thanks for your help.
You are right, activation of [POD_SLOWCLK] option can be neecessary only for very old non-iso version of emulator (internally based on legacy TI SN74ACT8990 emulation controller). For "iso", "iso v.2" or new "Lite" emulators this option only reduces performance.

We have SAU510-USB ISO_PLUS and licensing CCS v.5.5 (under Wind7)
Latest driver we instaled is:
But CCS v.5.5 don't see the driver at all.
What can we do?

Thanks, Alexander
Edited: Alexander Perepechai - 19.11.2014 14:11:07
Pages: Prev. 1 2 3